Back to the Shapespark home page

Black background


#1

when do a preview bake i get a black background, which is what I want
but when I do the real bake I get a white background which is what I don’t want
what should my settings be?


Thought I would add a wishlist to the mix
#2

You can try to load a black Sky Texture (Settings Sky) as background.


#3

that works in walk mode but not in orbit mode


#4

As per this topic we will add a per-view checkbox that will allow you to enable the sky texture independent of the type of the view. It will be released next week.

For now, as a workaround you can add a box enclosing your scene in the 3D modelling program. The box should have faces oriented inwards and a black material on them. To optimize the baking time and scene size it would be best to set Custom lightmap resolution for the box to 0 in the Objects tab.

If you’re using sky light to illuminate the scene the box will block it. You can, however, set the opacity of the box material to 0 for the baking time, and revert it to 1 when the scene is baked.


#5

Hello @bray, did you have a chance to try the latest release? You can now use the black sky also in the orbit mode.