Back to the Shapespark home page

How to remove bake artifacts in corners/seams?

Hi devs, do you have any tips on how to remove bake artifacts around seams and corners? They are prevalent in my scene after baking at 150 resolution and 1200 samples. There are no overlapping UVs. Could the UV spacing between UV shells be too close together? Scene: https://impulse.shapespark.com/birch_model_03/

1 Like

Hi!

Your scene has bright illumination, so the default value for the Flood dark limit in the Bake tab is too low. Could you experiment with increasing it to a value in 0.04 - 0.08 range, the lower the better. After each you change to this value you have to re-run lightmap post-processing with the Post-process button.

More information in this post:

Thanks! This looks like it’s helping, but I’m having to use high values of 0.10-0.15 to get it to remove them completely. At 0.05 there’s hardly any difference and at 0.08 they’re reduced, but still prevalent.

Hi @wojtek, I have the same problem and I already down flow dark limit to 0.01 and nothing change, what else I can do to fix this?

This is the scene https://all360.shapespark.com/190916_svh/

If this is caused by the floor dark limit you should increase the amount of it, not decrease it. Test something like 0.15.

Already put it on 0.15 and nothing happen, I will try rasin up more than 0.15 and will be back to comment.

@jorgearq,

This sofa has very detailed geometry at the edges, but it seems the geometry is not smoothed properly. Could you redo the Soften Edges operation in SketchUp for the sofa. Also, setting Custom lightmap resolution in the Objects tab to 100-150 should help.