Back to the Shapespark home page

I can´t use Windows Mixed Reality controls in WebVR (resolved!)


#1

Hi @jan and @wojtek, the experience into WebVR whith Shapespark scene is amazing! the level of realism is austanding but I try to move smoothly using the Windows Mixed Reality controls and is imposible. Is very frustrating because the experience is impresive but moving arround is simply dessapoiment. The only button that made something is pad key but teletransport you to the next wall in front of you, by just one hit!

I try to use arrow, and pg up or pg dn keys but it causes nausea.

In this page (https://docs.microsoft.com/es-es/windows/mixed-reality/enthusiast-guide/webvr) talking about webvr and controllers, they mention:

Not all WebVR content is authored to support motion controllers. WebVR allows developers of content to support different types of input, such as game controllers or motion controllers. If you do not see your controllers on a site, it likely doesn’t have motion controller support.

See the controls is not the important thing, the most important thing is can use it! because use arrow keys is very annoying and sad at the same time.

Do you get plans to improove this in a short time of period?

You mention Some gamepads can be configured to simulate keyboard events do you know if I can use another type of controls with Windows Mixed Reality headset instead of that I have?

BTW in the same page that I mentioned above appears this picture, maybe help you.


#2

For teleportation, there is a white dot in the center of the screen in VR mode that determines the teleport destination. You can move your head to place this dot at a place where you would like to teleport to, for example on a floor nearby, and the teleport should take you there.

Using controllers for walking is not supported (in general, not just with Mixed Reality). Walking in VR without physical movement of your body causes nausea no matter if you use keyboard or controllers. This is why so many VR experiences use teleport based navigation.

At this moment we don’t have plans for more sophisticated controls in VR. There are too many different headsets and controllers in use and also WebVR browser support is changing too fast for us to be able to provide such support.


Oculus experience
#3

Thanks @jan. I understand what you say.

In this moment, to feel the most realistic experience of the space we are traying this:

  1. Find a place big enough and very well illuminated
  2. Set up shapespark scene in WebVR mode and Put the laptop in a backpack to carry on with headsets
  3. Literally Walking around with the equipment.

Is crazy but is worth it! You feel like truly be there!


#4

Hi @jan, how I can slow down the speed of the left/right arrows or 4-6 number keys? I can control the speed of camera and that settings change the speed of forward/backward/Up/Dn keys but not left/right. The change of the speed of the rotation help a lot to cancel nausea sensation

I find something extrange making experiments trying to move in VR on pc. I find sometimes that i’m not the center of the rotation when I use the arrow key. Look this video to understand better. https://www.dropbox.com/s/oox7i50ihs0qdnf/I%20am%20not%20the%20center%20of%20rotation.mp4?dl=0


#5

Changing the rotation speed is not possible, but we will expose some way for you to experiment with different speeds.

I’ll also take a look on why this rotation center problem is happening.


#6

We have a fix for the rotation problem, it will be released tomorrow. For the rotation speed, for now we are exposing a constant that can be changed from body-end.html file, I’ll post instructions tomorrow.


#7

Thanks @Jan, you always do magic! I will be attentive to the indications tomorrow. Thanks again. :+1:t3::ok_hand:t3::clap:t3:


#8

The fix is available on the Shapespark hosting.

To change the arrows turn speed, place a file called body-end.html in your scene folder with a following content:

<script>
  (function() {
    // How much per second the camera turns with right/left arrow keys.
    // (the default is Math.PI / 2).
    WALK.CAMERA_ARROWS_TURN_SPEED = Math.PI / 10;
  }());
</script>

This code changes a global constant that controls the arrows turn speed (by default the arrows turn by PI/2 radians per second).

Until the next desktop application release is available you need to upload the scene to test the effect.


#9

Thanks @Jan, I’ll try in a moment and make comments about it.


#10

Hello, @Jan, I already did the tests with the HTML file that you gave me, it works much better. However I feel the issue of nausea is not completely eliminated.

The way you could advance in WebVR is doing it just like they do in web games: buttons to move forward and backward to where you direct your eyes, but only turn with your head and not with control.

If you do not have the enought space to moving with the VR equipment, teleportation is the best option. However, waiting blue circle loading is sometimes tedious. We have solved this with a simple control that made teleportation by pressing a button, this allows you to travel the space quickly whithout nausea feelings.

This is the picture of the control we use, te settings are @+D (mouse mode) and press R1
Note: the cursor need to be on edge window, if not, control does not function.

utopia%20002


#11

To understand correctly, are you using this controller for VR with an Android phone and cardboard? For Microsoft Mixed Reality you should be able to activate the teleport with the standard Mixed Reality controller, is this the case?


#12

Hi @Jan
To clarify this about controls:

  1. Are you using this driver for VR with a phone and an Android card? Yes, but nothing happens.
  2. For Microsoft Mixed Reality, you should be able to activate the teleport with the standard mixed reality controls, is this the case? No, I can not use the Windows mixed reality controls in any way.

So … I tried to mix
I used the Utopia control in Win 10 + Edge + Mixed Windows Reality via Bluetooth to teleport and I did it!

I tried these combinations

  1. iPhone VR mode and Utopia control, nothing happens.
  2. iPhone VR mode and Nimbus Steelseries game control, I can teleport with the B button, the other buttons do not work.
  3. Oddyssey Headset and controls + Edge + Windows Mixed Reality and I can not move whith any control buttons. Whith this combination I did move whith arrow keys
  4. I did tried to pair Steelseries control on Win 10 without succes.


#13

Could you tell me exactly which button make the teleportation posible in mixed reality standard control please?


#14

With our headset teleport can be activated with the right hand controller (left hand controller is not supported). Following button work: round top button, front button or joystick down click.

Do you see your controllers in the Mixed Reality Portal application? We sometimes loose them (‘Lost tracking’ status in the portal), in such case a series of controller restarts usually helps.


#15

Thanks @Jan, now I can use right WMR controller buttons that you tell me to teleport. You are right, sometimes lost tracking issue cause controller not function.