Back to the Shapespark home page

Issues with the quality in VR

Hi Everyone,

My house has a lot of details, which could result in a reduced quality scene. Although, I am not happy with my scene in VR through my phone. How can I achieve a better view like the example room from SketchUp. In some cases, I even use the same materials but the outcome is not comparable on my property to the sample room. For some reason, the edges are not as straight as they should be.

What do you think, could I get a more realistic view with an Oculus headset? Is there another brand/ product you would recommend.

https://oliverf.shapespark.com/3_bedroom_house/

Thank you,

Oliver

For performance reasons mobile VR uses reduced resolution. You can increase it using a following URL hash: https://oliverf.shapespark.com/3_bedroom_house/#vrhi but you need to check if it will run fast enough.

In general you can improve the quality of the scene both in VR and normal mode by baking with larger number of samples to reduce the noise. Instead of 150, try 800 samples. You can also decrease opacity of windows and curtains for the time of baking to allow more daylight inside. For example bedroom curtains have 0.2 opacity and windows behind 0.1, try setting something like 0.01 for both curtains and windows. You can increase it back after the baking.

1 Like

Hi Jan

Thank you so much for your help, I will try and get back to you soon.
Do you think can we change my user name from
oliverf .shapespark to epix-digital.shapespark somehow?
Or do I have to create a new account?

@oliverf it is renamed now: https://epix-digital.shapespark.com/3_bedroom_house/ (you will need to login again to the Shapespark desktop application using the epix-digital username)

Hi Jan,

Thank you very much for your help. I appreciate this excellent customer service.

Hi Jan

I had baked my scene again in 800 samples, and I had adjusted lights as well. It has changed a lot, but the quality in VR on my phone is still not the best. Can I improve the quality somehow?
And also which VR glasses would you recommend to achieve a more realistic view?

https://epix-digital.shapespark.com/3_bedroom_house/

Thank you

Did you try also with the hash #vrhi hash? https://epix-digital.shapespark.com/3_bedroom_house/#vrhi

Desktop VR devices: Oculus Rift and HTC Vive have better quality than mobile.

Samsung Odyssey HMD is also a excelent VR to live Shapespark experience!

@oliverf Very nice model!

Dear Guys

I have got an idea but I am not sure if it is going to work. I just need some help. I would like to make the walls adjustable. I think if I put a different length of walls on the same spot in my project between two rooms, and I set the material picker from colour to glass, it could work, is in it? For example, the wall between the kitchen and the living room could disappear on the client’s request.
Also, instead of using material pickers could I change the textures with the viewpoints somehow?

Thanks for your help in advance

You can use Hide in views functionality to hide objects in the Objects tab. You can add views like for example ‘Walls option 1’, ‘Walls option 2’.

You will likely need to make the parts of the walls that can be hidden transparent for the time of baking, so the walls do not cast shadows that would leave dark spots when the walls are hidden.

Thanks for your quick response. I tried that already, that is really cool.
Can you please advise on how can I change textures with view points? Do I have to hide objects with different textures at the same position?

Yes, hiding objects is the only option. See ‘Kitchen Style 1, 2 ,3’ views in the scene linked in this forum post: R&D Home walk-through

Thanks for your help. My test apartment was born yesterday.
https://epix-digital.shapespark.com/apartment_example/

3 Likes

Nice! It isn’t very noticeable that the configurable wall doesn’t cast shadow.

Hello Jan,

I have changed the surfaces in one of my projects. I baked it first, and then, I tried to set the info points. When I edit the info point textures / Kitchen bench-tops / the textures work well. But when I upload the project, for some reason the textures do not work. I tried to set the scaling of the textures a couple of times but nothing has changed.
What do you think, what could cause this problem?

https://epix-digital.shapespark.com/apartment_example/

Thank you for your help in advance,

Oliver

Hi Olivier,

Do you mean that some of the material pickers in https://epix-digital.shapespark.com/apartment_example/ are not working as expected?

This looks like an issue with texture atlasing: