Back to the Shapespark home page

No functionality of the control menu


#1

Hi.

I have a client with a self-hosted scene. The custom start image appears, but no play button. What can be the reason for this?

Here is the link: Scene Schwanen Villa on client-server

And a screenshot from the backend:


#2

Hi @tim,

Your client hosting is powered by the nginx HTTP server. Self-hosting with nginx doesn’t work out-of-the box, as is the case with Apache HTTP server, because nginx does not support per-directory config files that could be provided inside the bundle. So, some global configuration changes are necessary to handle the scene resources which are precompressed.

The nginx configuration snippet that is provided in the bundle - .nginx-location.conf has to be manually added to the global nginx configuration. Could you ask your client if it would be possible for their IT staff to include this configuration? If not, we will send you an uncompressed version of your scene that doesn’t need such configuration changes.

(For reference, self-hosting with Apache HTTP works out-of-the-box, because Apache supports reading configuration for a scene directory from .htaccess provided inside the bundle.)


#3

I guess you mean to send a uncompressed version that doesn’t need the configuration?


#4

You are right. I’ve edited my post to correct this.


#5

Okay. Thank you, Wojciech!


#6

It would be helpful if you can provide the unpacked version as you explained. Thank you.


#7

@tim, I’ve sent you the uncompressed version via PM.

One note: if there is no HTTP server configuration for the scene, then it’s best to upload new versions of the scene to new directories (URLs). This will prevent recurring visitors from accessing some old versions cached in their browsers.


#8

Thank you Wojciech! I will forward this information to my client.


#9

@wojtek
The client uploaded the file. I tested it and it works fine. there is just one thing which shouldn’t be. When I enter the full-screen mode by pressing F and then chance to the “enhanced” full-screen mode by pressing L and then want to disable this mode by pressing L again the window switches back to the small screen layout. In my opinion, this shouldn’t happen. It should still be full-screen.


#10

@tim, thanks for the report. There is indeed a bug with this behavior. It’s been fixed. The fix will be applied to the scenes hosted on our infrastructure today, but self-hosted scenes will need to wait for re-bundling with the next Shapespark release.