Back to the Shapespark home page

No functionality of the control menu

Hi.

I have a client with a self-hosted scene. The custom start image appears, but no play button. What can be the reason for this?

Here is the link: Scene Schwanen Villa on client-server

And a screenshot from the backend:

Hi @tim,

Your client hosting is powered by the nginx HTTP server. Self-hosting with nginx doesn’t work out-of-the box, as is the case with Apache HTTP server, because nginx does not support per-directory config files that could be provided inside the bundle. So, some global configuration changes are necessary to handle the scene resources which are precompressed.

The nginx configuration snippet that is provided in the bundle - .nginx-location.conf has to be manually added to the global nginx configuration. Could you ask your client if it would be possible for their IT staff to include this configuration? If not, we will send you an uncompressed version of your scene that doesn’t need such configuration changes.

(For reference, self-hosting with Apache HTTP works out-of-the-box, because Apache supports reading configuration for a scene directory from .htaccess provided inside the bundle.)

I guess you mean to send a uncompressed version that doesn’t need the configuration?

You are right. I’ve edited my post to correct this.

Okay. Thank you, Wojciech!

It would be helpful if you can provide the unpacked version as you explained. Thank you.

@tim, I’ve sent you the uncompressed version via PM.

One note: if there is no HTTP server configuration for the scene, then it’s best to upload new versions of the scene to new directories (URLs). This will prevent recurring visitors from accessing some old versions cached in their browsers.

Thank you Wojciech! I will forward this information to my client.

@wojtek
The client uploaded the file. I tested it and it works fine. there is just one thing which shouldn’t be. When I enter the full-screen mode by pressing F and then chance to the “enhanced” full-screen mode by pressing L and then want to disable this mode by pressing L again the window switches back to the small screen layout. In my opinion, this shouldn’t happen. It should still be full-screen.

@tim, thanks for the report. There is indeed a bug with this behavior. It’s been fixed. The fix will be applied to the scenes hosted on our infrastructure today, but self-hosted scenes will need to wait for re-bundling with the next Shapespark release.

1 Like

Hi,

I’m having some problems with self hosting on Apache and just receiving a static image

Solved *

See all the terminal commands for setting up a ubuntu vps self host.

apt-get install apache2
apt-get install php libapache2-mod-php
apt install libapache2-mod-security2 -y
systemctl restart apache2
apt install libapache2-mod-evasive -y
systemctl restart apache2
apt-get install php libapache2-mod-php
apt-get install php5 libapache2-mod-php5 php5-mcrypt
a2dismod deflate
/etc/init.d/apache2 restart
a2enmod headers
/etc/init.d/apache2 restart

@papergh0st the server is not returning Content-Encoding: gzip header for resources that are compressed, so the browser fails to parse them. Did you use the .htaccess file included in the bundle to configure the Apache? It includes rules that should set the Content-Encoding:

RewriteEngine On
RewriteRule "\.(bmp|buf|json|ktx|svg|ico)$" - [E=no-gzip:1]
<FilesMatch "\.(bmp|buf|json|ktx|svg|ico)$">
  Header set Content-Encoding gzip
</FilesMatch>
<FilesMatch "^(index\.html|cover\.json)$">
  Header set Cache-Control "no-store, no-cache, must-revalidate, max-age=0"
</FilesMatch>