Back to the Shapespark home page

Nginx self hosting with Siteground not working - Please help!

Hello enveryone.

I have switched from godaddy servers (Apache) to Siteground (Nginx) yesterday. Siteground is great but the self hosting does not function.

I get a still image -> no play button

1 - I decompress the zip file on my local Mac
2 - I upload with File Zilla the decompressed files and folder
3 - Using bianary transfer type
4 - All the folders and files are present on the nginx server
5 - I have tried to upload the Zip file but the server does not recognize it nor lets me open it.
6 - Link to the tour : Link to 3D tour
7 - I have tried this as well : Link to 3D tour
8 - I have found this topic covering what seems to be a part of the answer :
Nginx thread
9 - Thread is suggesting todo the folowing : The nginx configuration snippet that is provided in the bundle - .nginx-location.conf has to be manually added to the global nginx configuration
I do not know how to do this. Is there an intruciton manual or a step by step tutorial available please?

I would greatly appreciate your help in finding a solution to this pain in the neck problem as my clients are waiting for their spaces to become available again.

Thank you

Unfortunately, there is no standard procedure for doing this on any WWW hosting provider. What is more, it may not be even possible on nginx servers shared for multiple WWW accounts. I don’t have any experience with SiteGround, and quick search for “nginx config/configuration” in their knowledge base didn’t show anything relevant. I think you’d have to ask their support if it’s possible and how to change nginx configuration.

From what I see, SiteGround offers Apache hosting as well. Would it be possible for you to switch the hosting to Apache? It seems to support .htaccess files, so Shapespark bundles should work out of the box then.

Thank you for your input Wojtek. Greatly appreciate your input. Here is what I have gotten from Siteground support team:

I checked the provided links and I was able to recreate the issue.

In order to resolve it, I have disabled the Nginx Direct Delivery from your Site Tools > Speed > Caching.

Now the page is loading as intended:

https://virtualvisitpro.com/Imagine/C21Horizon/Bernissart/

Please make sure to clear your Browser’s Cache and to verify the results on your side as well.

As the page is serving only static content it has been affected by the cache when it is enabled.

I would suggest you not use for this type of website in the meantime in order to prevent the issue in the future.

In any case, you may get some more information in regards to the Nginx Direct Delivery on the following page:

If we could be of any further help, do not hesitate to contact us again.

The links now do work. I am just waiting to see if this process is slowing down the site or not.

I hope this will also help others in my situation.

Have a great day and look forward talking to you soon.

If I understand the SiteGround’s answer correctly, what they turned off is SSD-based cache for nginx, so now for most of the resource requests the nginx server will have to fetch the resource from the Apache server, instead than trying to first locate it in the SSD cache.

I don’t think it should affect the scene download time much, since the user’s internet connection will still be the bottleneck for a Shapespark scene.

BTW, not sure if you’ve seen this quite recent feature: Custom domain support If having your own domain in the scene URL is the most important reason for own WWW hosting, then the alternative could be using this feature, which allows to use our hosting infrastructure (and upload scenes with the “Upload” button) with customer’s own domain.