Back to the Shapespark home page

Object Switch & Lighting / Baking

Hi,

I have a scene set up with the Object Switch extension to turn off the ceiling to show it as exposed, which works as expected. However, when the ceiling is off, the lighting behind where the ceiling was is too dark. I have tried to place some point lights behind the ceiling, which does work, to some degree, however, as the level of the interior wall finish changes it doesn’t solve the issue.

Here are a couple of screenshots:

Does anyone have a workaround for this, or is there another way I could set up the model to avoid this issue?

It would almost be great if I was able to bake it with each option, but I do appreciate this would be prohibitive in larger scenes!

Any help much appreciated.

Thanks a lot!

You can try setting Isolate shadows option for the ceiling in the Objects tab. With this option all other objects in the scene will be baked with the ceiling hidden. Ceiling will still be baked, so it shouldn’t look detached from the surroundings.

1 Like

Thank you so much Jan, that has worked perfectly!

Apologies for brining this one back up - I have a similar issue:

When using the Object Switch extension with reflections in the room, as in my example, a bathroom, the objects change but the reflection stays the same as the initial object. I have tried adding the mirror to each of the object switching groups thinking this might rebake it for each option, however, this didn’t work.

Is there something else I can try?

Thanks!

Currently it is not possible to update the reflections. See also: Update Lightprobe reflections when objects are turned off and on

Thank you for the reply, @jan, and the link to the other post. That is a shame; I can see this being a frequent issue I’ll run into.