Back to the Shapespark home page

Occasional WebGL Problems


#1

I am suddenly getting WebGL problems. On a couple of instances in the last few days, I have gotten the following message:
No-WebGL

Both times that this has occurred, the render went for at least 6 hours. I have been able to fully render on several other occasions. Any ideas about what may be causing this?

I have an NVIDIA 765M graphics card and I am running Win 10 on my laptop.


#2

Do I understand correctly that you have been experiencing such an error in the last few days, but you had never seen it before?

Could you answer the following questions to help us troubleshoot the issue?

  • Are you rendering using a CPU device or a CUDA device?
  • Is it possible that this error occurs only when or after you cancel the preview or baking process?
  • Has your scene size increased significantly recently?

#3

Yes, I started seeing the problem this week.

  • I am rendering with CUDA (NVIDIA GTX 765M)

  • I do use the Preview function but do not start the Bake process more than once

  • I did add some bushes and trees which add a lot in SketchUp

I am currently trying another Bake which has been running 6 1/2 hours already and still has a long way to go based on the feedback I am seeing. I might have to stop it before it is done :worried:

Well, I just got the message again. I was on the step of eliminating seams for 8 of 8 and I cannot do anything with it. Here is a screen shot of what it looks like (full screen)


Notice that all of the controls on the right are gone. I also tried the Window>Reload to see if it would show anything else. It did not. :disappointed:

I forgot to mention that this took 8 1/2 hours.


#4

It seems that the error occurs when the scene is reloaded after baking. So, your scene has been most likely successfully baked, but the editor is unable to show it. Could you restart Shapespark and check if this is the case.

May I have a few more questions?

  • Could you upload the current version of your scene so that we tried to reproduce the error?
  • Have you always used CUDA device for baking or did the error start to occur after you had switched from CPU to CUDA?
  • How much video RAM does your video card have, and how much RAM does your computer have?
  • Do you have the most recent video card drivers?

By the way, 8 lightmaps seems like a lot. I think it should be possible to decrease this number - so also the baking time - by using Custom lightmap resolution for some large or distant objects in the scene.


#5
  • Do you mean upload the SketchUp file? If so, how & where do I do that? When I try to upload anything to the forum, it does not accept SketchUp files. I did upload the baked file from yesterday (just uploaded now). Looks somewhat acceptable in Chrome but still needs some changes. Looks bad in Edge. I would not want people to see it with Edge.

  • My first couple of bakes were done with the CPU. Then I switched to the CUDA and it was much faster. Problems to have started after adding the shrubbery and trees. There are other things I would like to add but cannot do it until this is resolved.

  • 12Mb of RAM and 2Mb on the video card.

  • I think all of my drivers are up to date.

  • You said 8 lightmaps seems like a lot. Where/how do I control that?

BTW: Why are your bulleted lists nice and compressed while mine are all double spaced.

I am afraid my trial is going to expire before I get this to a point that I can share it with the people I need to too. :frowning:


#6

I meant the baked version of the scene.

Your problems seem to be caused by the added shrubbery. If you go the the Objects tab in Shapespark and select one of the shrubbery objects, you will see that: each shrubbery object has 230k triangles (faces) and there are 22 such objects which gives 5M triangles out of 6M triangles in the scene in total.

I think this scene is now very near the memory limit of your video card with respect to CUDA baking, and that in certain cases it crosses the limit causing the error you have reported.

So, the easiest solution for your problems is replacing the shrubbery with some simliar objects having much simpler geometry (lower polygon count in the 3D Warehouse model info). It should also decrease the number of lightmaps, and shorten your baking times.

There should be no blank lines between consecutive items of the source text for you bullet list:

* Item 1
* Item 2

instead of

* Item 1

* Item 2

#7

This is kind of what I was expecting. I went back this afternoon and did some more reading and plan on making some hopefully significant changes tomorrow.

I agree but how do I stop them (the extra spaces)? I only see the 2 icons for list items and when I click on one it adds the extra space.


#8

I see. The list button always starts a new list, so it always introduces an empty line.

To add an item to an existing list you have to manually create a line starting from * (without preceding spaces).


#9
  • Item 1
  • item 2

:clap: Thanks


#10

OK - progress and backwards all at the same time:

  • Changed some settings and got the bake time down to about 1/2 hour and there was only 1 lightmap but had have some problems that I would like to resolve before adding additional equipment/features to complete the scene.
  • I think the biggest factor was removing all of the shrubbery. Got to find some lower poly versions so I can make the property look a little nicer. :slight_smile:
  • Changed the following settings:
  1. Reduced the lightmap resolutions to 15
  2. Set the Sky strength to .5
  3. Set the Ambient Occlusion to .05
  4. Set the Camera Exposure to 0.2
  5. Set the Camera Exposure to 0.9

First thing I need to resolve is the grass. Why does most of it show up as black in Edge. Looks ok in Chrome but a little lighter than I would like but is at least acceptable. I realize that there things are not going to look as photo realistic in the Microsoft browsers as others but at least everything must be fully visible. If this were to go on a public website, I cannot control what browsers a viewer might be using.

Any suggestions would be greatly appreciated.

I have now tried adjusting the Flood dark light and Lightmap resolution settings and nothing seems to eliminate the big areas of black I am seeing with Edge. Before I added the shrubbery (which I deleted) I did not see this big black areas.


#11

Recently we have found that an issue in IE and Edge related to imprecise loading of PNG lightmaps causes extremely bright areas to be rendered dark. It seems the grass area in your scene is affected by this issue.

We are working on a workaround for the IE/Edge behavior.

Meanwhile, you can decrease the strength of the sun from 50 to, say, 8. It should fix both:

  • the black grass issue - the grass will no longer be extremely bright, so it won’t be affected by the above issue,
  • too light grass issue - the grass will be darker than now.

#12

Once again, thanks very much for the feedback. I will give it another try and see what it looks like.

Edit: Just finished and it looks better in edge :+1:

Here is the latest version of my Carwash


#13

Your tips have definitely helped. Even thought I cannot upgrade to 1.5.5 yet, I am seeing some real improvements. I even added some more equipment (which once again needs some clean up) and the latest upload took less than an hour for baking.


#14

I just got upgraded to 1.5.5 (I am no longer using AVG). I like that the current view is now highlighted. :slight_smile:


#15

Good to know it’s working for you now. We’ll try to fix the issue with AVG anyway.


#16

I like the highlighting of the selected view but it would be nice if it stayed highlighted until you go to another view.


#18

In continuing to improve my scene (which is an older SketchUp model) and learn more about Shapespark, I have encountered some additional problems:

  • Material application - I have encountered a distortion in the application of a “concrete block” material to one of the walls. As you will see in these images, the material in applied the same on all of the interior walls in the SketchUp model but on one of the walls in the Shapespark editor it is applied incorrectly on one of the walls (all the rest are correct)

SketchUp BlockWall
Notice how the block material is the same on both walls.

Shapespark BlockWall-shapespark
Notice how the block material on the right wall is not applied the same.

  • Bleeding - In this situation I am seeing bleeding in the rendering of one of the walls. I checked to see if this might be some type of z-fighting but could not detect any.
    SketchUp Ceiling
    Look at where the ceiling and wall meet.

Shapespark Ceiling-shapespark
Again, look at where the ceiling and wall meet and the “bleeding” that is taking place.

  • View List - If you go to “full screen” in Edge, the view list shows up, however, if you go to “full screen” in Chrome the view list does not show up and the only way you can navigate the scene is by using the VR navigation keys.

Hope this information is clear and that someone can tell me how to correct the issues.

Edit I went back to SketchUp and tried to make a couple of adjustments but they did not result in any updates in the baked version that you can see. Just out of curiosity, before I baked the scene again, I looked at the 2 areas I mentioned above in Preview and they both seemed to be OK. Did not see the bleeding and the block texture looked fine in the Preview. I then baked it again and both problems persist. It is also interesting to note that when I look at the scene in the editor, the block texture does not look right but as I just said, it did look correct in the Preview. I am kind of stuck/stumped as to what to try next.

BTW: Maybe this discussion should be in a different thread?


#19

This seems like an issue in the WebGL viewer. We’ll be investigating it.

This is because a low lightmap resolution is used for baking. Lightmap resolution of 25 in this scene means that baking computes and stores light information with precision of a 4 x 4cm square (25 samples per 1m). Bleeding is a result of such lightmap squares covering the area both over and under the roof. (Bleeding is not visible in preview, because preview uses classical static rendering not based on lightmapping). There are two options to fix it:

  • Increase the lightmap for the building, to say 60, using the the Custom lightmap resolution option of the Bake tab.
  • Split the wall in two separate SketchUp groups, so that no light information will be shared among them.

Chrome supports a viewing mode where it hides the mouse pointer and allows to navigate the camera without holding the mouse button, like in FPS game. For such a mode the viewer menu, including the view list, is hidden, because with the mouse pointer absent they it are not clickable. Edge does not support such mode, so the menu is displayed there.


#20

We’ve analyzed this issue and the problem is that there are overlapping polygons on the walls. One of the overlapping polygons is textured to match the neighboring wall, but the other one - which is actually displayed - has the texture slightly distorted.

You can fix in SketchUp, but you can also hide the object which brings duplicated polygons in Shapespark. It’s named {[Concrete_Block_8x8_Gray]}Group#344. Please see the attached screenshot.


#21

Thanks for the feedback. Went into SU and think I was able to fix the problem. Re-baking now and will see how it goes.

Edit Got the wall fixed so now I am steeping up the lightmap resolution. Will upload when finished and these two problems are fixed.

Full Screen Mode since there are related to showing/not showing the view list in full screen mode, is there a way to disable it (full screen mode)?