Back to the Shapespark home page

Same scene, different events

Hey guys, first time writing on the community
I was wondering is there a way to have only one scene but two different sets of events, in this case html-description in 2 languages, so i can basically have only one scene in which i can select the language (which maybe i can do it preliminary on the website, it doesn’t have to be within the scene), and to have some kind of way maybe to call/trigger the specific kind of language.(different set of events)

So basically what the client wants it is the same scene but in two different languages, is there a way to Call different set of events.

Thanks

One way to achieve this would be to make a copy of the scene folder in Documents\Shapespark, edit HTML label descriptions and upload the copy. Then the main website can link to either first or the second copy depending which language the user has chosen on the main page.

1 Like

Ok, well that sounds great, i will try this out when I am at my work computer,
thank you very much @jan

Hey Jan

so i already edited the cover.json files for the second language, is there a way to make the scene index.html to an index_eng.html (second language) to call the edited cover_eng.json - with the new html labels, thank you, i will continue to try to find a way, i will notify you if i find it, thanks

Hi @ylli. It can be rather difficult to make your approach with cover_eng.html and index_eng.html work. Copying the whole scene to have two completely separate scenes for two languages would be easier.

Hey Jan,

sorry for asking here, is there a way to increase the quality of the vr scene when viewed from the Oculus Browser, on OQ 2, i have already done the duplicate textures on larger surfaces, on the phone and on Pc textures looks fine, is there something that we can do.

We will see tonight if the browser maybe by accident was set on mobile, ill inform u,

Thanks

Do you find the quality of the textures too low when viewed in VR, so covering a much larger field of view than on the computer display? If so, you can disable the GPU compression formats and/or Auto scale resolution texture setting, as described in: Texture change before and after bundle - #2 by wojtek